Anonsurf does not work

Hi, I use VPN on network manager and today I played with iptables so I can use killswitch. Ok but now when I turn on anonsurf is turned on but it does not load website, does not ping, and even does not show any ip when is anononsurf option to check ip…Even I reinstalled anonsurf. I think it’s iptables fault, would be awesome if somebody could help me.

Thanks.

anonsurf is a script. just look inside and your eys will be open! ;+)

2 Likes

I am not really into code, maybe you will help me? :slight_smile:

show us the output of sudo iptables -L -n -v

1 Like

Solved :smiley: Already it’s happens because I made vpn kill switch file named “firewall.sh”

#!/bin/bash
sudo ufw reset
sudo ufw default deny incoming
sudo ufw default deny outgoing
sudo ufw allow out on tun0 from any to any
sudo ufw enable

It’s blocked because of that, but after I disabled UFW firewall anonsurf work normal again but my kill switch does not work as my firewall is disabled…Could somebody add a rule so my kill switch will work but also anonsurf mode will work normal?

Thank you.

I gave up on Anonsurf. It would work when the firewall was disabled but wouldn’t work even when I added the correct ports. I just use a manual SOCKS5 proxy now to route all my traffic through Tor.

1 Like

Can you tell me how you use socks5 to route all traffic over tor?

Make sure Tor is enabled ‘sudo service tor start’ then go to Network Proxy settings. Click Manual proxy configuration, then in the Socks host box type in ‘localhost’ and then 9050 for the port number. Then allow the 9050 port as outgoing to your firewall. To test it ‘ping ipv4.icanhazip.com’, if you get a different IP address than your actual one then you know it’s working. I tested this over my VPN on https://tenta.com/test/ and I was positively identified to be using a Tor exit node. You’ll also want to configure your programs to use the same proxy.

If I’ve missed anything out please feel free to add to it anyone :slight_smile:

1 Like

If you are super paranoic then use Vpn+Anonsurf then VM machine and there socks5 : )

Haha yeah I already do

i think thats everything else than anonymous. You would have to many hops. See here
Its also discussed several times on the Tor subreddit. Here are a few posts:



This is a wild guess, but I had some problems with Anonsurf too. If Anonsurf does not work for me, I select “Anonsurf Stop” and then “Anonsurf start”, and then it works for me. Not sure if it works for you.

1 Like

It’s work normal already after I disabled uwf firewall…

This happened to me when I first installed Parrot. It wouldn’t work the first time. But it seemed to be fixed after I installed the next update. Haven’t really used it since then though.