Can't Stop Default User Autologin

Running a new Parrot Home 4.7 OVA in VirtualBox 6.0.14 on Windows 10 x64 Pro 1803 running from a USB flash drive (quasi Windows To Go).

I have added my own standard user account to the default Parrot User account. I would like to log in using that standard user account. Unfortunately, Parrot User insists on autologin. How can I stop that? The User Settings dialog for Parrot User claims that password is “Asked on login,” but this is not the behavior I am observing.

After Log Out, Switch User, or reboot, Parrot User immediately logs in again, allowing no time for me to choose a different user. The Change option in the User Settings dialog does provide a “Don’t ask for password on login” option, but that is unchecked; moreover, it is greyed out.

The objective is to delete Parrot User, based on someone’s advice. I’m open to suggestions that this is inadvisable, or that there is a better way to achieve that.

Have you installed Parrot in Virtual Box?

Sorry, I don’t understand the question. You see the statement of what I’m running, right?

VirtualBox OVA install does not allow you to enter a password, you need to install the ISO version.

1 Like

Greetings all new parrot user here and first post!!!
To fix the auto login issue you do the following!
Note: I have tested this in the vbox image.

Edit :

/etc/lightdm/lightdm.conf

Comment out these 2 lines:
From:

autologin-user=user
autologin-user-timeout=2

To:

#autologin-user=user
#autologin-user-timeout=2

Then you should be able to log in with the user you want.

1 Like