Help with apt

Hi ! .
i’ve got problem with apt-get update, that’s the output when i run “sudo apt-get update” and i cannot use any apt command whenever I try to use apt it give me error(“E: Il valore “buster” non è valido per APT::Default-Release poiché tale release non è disponibile dalle sorgenti”)

"

Operating System: Parrot GNU/Linux 4.7
Kernel: Linux 5.3.0-3parrot3-amd64

graphic installer from usb created with unetbootin

Configured to multiboot with other systems? yes windows 10 home

If there are any similar issues or solutions, link to them below: nothing i can found

If there are any error messages or relevant logs, post them below:

run>>“sudo apt-get update”

Trovato:1 http:// package s. microsoft. com/repos/vscode stable InRelease
Ignorato:2 http:// dl.goog le. com/linux/chrome/deb stable InRelease
Trovato:3 http:// l.google.c om/linux/chrome/deb stable Release
Scaricamento di:4 https:// deb. parrotlinux. org/parrot rolling InRelease [14,4 kB]
Scaricamento di:6 https:// deb.parrot. sh/parrot rolling InRelease [14,4 kB]
Scaricamento di:7 https:// deb. parrotlinux. org/parrot rolling-security InRelease [8.749 B]
Scaricamento di:8 https:// deb. parrot. sh/parrot rolling-security InRelease [8.749 B]
Recuperati 46,3 kB in 1s (38,0 kB/s)
Lettura elenco dei pacchetti… Fatto
E: The “buster” value is not valid for APT :: Default version since this version is not available from the sources

Thanks in advance.

please just use

sudo parrot-upgrade

apt upgrade will destroy a rolling distro!

2 Likes

thx for the fast response i will use “sudo parrot-upgrade” but now i can’t use apt how to fix it ? thx in advice

ups, maybe u should read the hole text nexttime … ;-

  • please use etcher for creating usb stick
  • fix your source.list … parrot is not buster
  • if you add 3 party sources … you could break your system
  • never use apt-upgrade

sourcelist changes

2 Likes

ok i’ve followed your suggestion, i’ve tryied to fix the source.list in /etc/apt/sources.list.d/parrot.list but the problem remain i’ve pasted in parrot.list this:

this file was automatically generated by parrot-mirror-selector

deb https://deb.parrot.sh/parrot/ rolling main contrib non-free
#deb-src https:// deb.parrot.sh/parrot/ rolling main contrib non-free
deb https://deb.parrot.sh/parrot/ rolling-security main contrib non-free
#deb-src https:// deb.parrot.sh/parrot/ rolling-security main contrib non-free

command:

sudo parrot -upgrade

the output is the same

E: Il valore “buster” non è valido per APT::Default-Release poiché tale release non è disponibile dalle sorgenti
failed to update index lists
Lettura elenco dei pacchetti… Fatto
E: Il valore “buster” non è valido per APT::Default-Release poiché tale release non è disponibile dalle sorgenti
failed to fix conflicts
Lettura elenco dei pacchetti… Fatto
E: Il valore “buster” non è valido per APT::Default-Release poiché tale release non è disponibile dalle sorgenti

and i can not even use apt
really sorry but i’m a newbie with linux world thx in advice