Parrot upgrade error

Hi! Can you write more information about your system? (default format should be in create new topic).
Have you run sudo apt update before full-upgrade command? because i’ve checked and this python-rfidiot showed latest version.

1 Like

I’ve been roaming for quite a while now for this problem, finally someone opened it up :slight_smile:
There was also an other package giving an error, but I installed it separately and it was gone. This python-rfidiot on the other hand says that it is already installed with the newly version available, but when I do sudo apt full-upgrade or sudo parrot-upgrade this error comes up.
The update command is also giving a warning:
W: Conflicting distribution: https://deb.parrotsec.org/parrot stable InRelease (expected stable but got rolling)

P.S. I edited the parrot.list file with the text found in the FAQ section, if changing a mirror helps.

Version: 4.19.0-parrot4-28t-amd64
Edition: Parrot Security /MATE
Installation Method: Debian Standard
Multiboot: No

Hello sir, my sytem details :
Version : 4.19.0-parrot4-28t-amd64
Edition : Parrot Security /MATE
Installation Method : Debian Standard
Multiboot : No

And i also run sudo apt update and there is a problem also …

W: Conflicting distribution: https://deb.parrotsec.org/parrot stable InRelease (expected stable but got rolling)

After updating my system then i run sudo apt full-upgrade But this problem occurs , what can i do?
Can you please explain about stable vs rolling ?

my parrot.list file :
deb https://deb.parrotsec.org/parrot stable main contrib non-free

If i edit stable to rolling then update warning not showing but upgrade error exists.

Is it occur any problem if i change source.list stable to rolling?

ah quack i am a little tired of that warning. People keep asking about it so much. It is nothing, trust me. We just change the edition name. Rolling and stable is just like Debian stable and testing (you can read it on debian doc). About this package problem, it is possibly package version conflict from Debian side (we pull from their repository).

1 Like

So, can’t get an upgrade right now?

Yo,
For you and/or anyone else running into this issue after edition name changes, just run the upgrade command.

`sudo apt-get upgrade`

If you’re still running into issues:

sudo apt-get autoclean && sudo apt-get purge
sudo apt-get update && sudo apt-get upgrade

Dont use “apt upgrade”, the best option is either full-upgrade or dist-upgrade especially with a rolling a release because simple upgrade doesn’t handle dependencies completely. It won’t nuke a system instantly but eventually it will cause you problems.